Setup Cisco Wireless Controller and Cisco Aironets

This article is a quick overview of setting up a Cisco Wireless LAN Controller (WLC 2100) with various Cisco Aironet access points. The Cisco Aironets are the lightweight version.

They are configured as shown below:

Configure the WLC via using the initial setup wizard

  • Connect a console cable to the WLC and using hyper terminal/putty, run through the initial setup wizard.
  • Give the WLC an address on your internal network and specify the internal DHCP server
  • In this example I have set the management IP to 192.168.60.20 and the AP manager IP as 192.168.20.21
I have set the virtual gateway as 1.1.1.1
Example output from the initial setup….

Enter Administrative User Name (24 characters max): triangleit
Enter Administrative Password (24 characters max): ***********
Re-enter Administrative Password                 : ***********
Management Interface IP Address: 192.168.60.20
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.60.1
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1 to 8]: 1
Management Interface DHCP Server IP Address: 192.168.60.1
AP Manager Interface IP Address: 192.168.60.21
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (10.10.0.1):
Virtual Gateway IP Address: 1.1.1.1
Mobility/RF Group Name: ROD-Group
Network Name (SSID): ROD-Wifi
Allow Static IP Addresses [YES][no]: YES
Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.
Enter Country Code list (enter ‘help’ for a list of countries) [US]: GB
Enable 802.11b Network [YES][no]: YES
Enable 802.11a Network [YES][no]: no
Enable 802.11g Network [YES][no]: YES
Enable Auto-RF [YES][no]: YES
Configure a NTP server now? [YES][no]: YES
Enter the NTP server’s IP address: 91.121.19.179
Enter a polling interval between 3600 and 604800 secs: 36000
Configuration correct? If yes, system will save it and reset. [yes][NO]: yes

Configure the Switches

If you are using different VLAN then you will need to set the ports that the WLC and access points connect to as trunk ports. Below is an example of the switch port configurations I used:

Wireless Access Point port:

interface FastEthernet0/1

description Wireless Access Point

switchport trunk native vlan 10

switchport trunk allowed vlan 10,20,30,100,101

switchport mode trunk

switchport nonegotiate

WLC port

interface GigabitEthernet3/0/20

description Wireless Controller

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 10,20,30,100,101,200,201

switchport mode trunk

Note that if you are having different wireless networks for specific vlans then you can configure a specific interface on the WLC for this. The port that this connects to needs only to be setup for a specific vlan.

Further Configure WLC

Set the date and time – it is import these are all in sync.

 

 

 

 

 

Configure Aironets

  • Logon to the WLC via the management IP
  • The Cisco Aironets are configured to pickup there IP addresses via DHCP and will automatically check in to the wireless controller.
  • From the below screen you can name the access points and give them static IPs

Create a WLAN network

Create a wireless network. Select the management interface unless you have created a specific interface.

Create dedicated interface (optional)

As discussed above you can create a dedicated interface on the WLC if desired. The switch port this connects to needs only be setup in “access” mode rather than “trunk” mode.

Note make sure you specify the correct DHCP server address or this will not work. Below is example switch port configuration for this extra interface.

interface GigabitEthernet3/0/16
 description wireless controller - gm3 interface
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast

Comments 1

  • It is highly rmmoceended to NEVER put a trunk port in spanning-tree portfast to prevent broadcast storms and Cisco switches will not put a trunk port in portfast mode anyway so this line is useless in this case.

Leave a Reply

Your email address will not be published. Required fields are marked *