Setup Powerconnect 5524 switch stack for iscsi use

This article explains how to setup 2 Dell Powerconnect 5524 switches for use in an iSCSI environment. It assumes that the Dell switches are in a factory default state. This script creates 2 vlans with ports 1/0/1-16 & 2/0/1-16 used for iSCSI traffic and ports 1/0/17-19 & 2/0/17-19 used for vmotion. Note the both switches are linked via 2x HDMI stacking cables. These are standard HDMI cables bought from my local supermarket at £6 each! To confirm the stack is operational look at the “Stack no” LED on the front panel which should say “1” and “2” on the respective switches.

I have split the script into parts for a better understanding of what each part does. Please connect your PC to the serial port on the back of one of the switches and use a terminal emulation program such as putty to paste in the below commands. As the switches are in a stack you can configure both switches from 1 console port. You will need to enter “enable” and “configure” modes.

Note – Enabling iSCSI mode will switch on jumbo frames, flow control, spanning-tree port fast, unicast storm control and enable the switch to automatically detect an Equallogic Array connected to any of its switch ports. After speaking to Dell Support I have found out that it is not recommended to “enable iSCSI mode” or flow control with the 5524 and 5548 model switches when used with an equallogic array. This is due to the current implementation of flow control on the current firmware (May 2011). I have modified the instructions below accordingly. I expect this to be addressed in a future firmware upgrade.

Part 1 – Set Hostname and Enable iSCSI mode

The instuctions below assume the switch will just be used for iSCSI traffic and won’t be used on the LAN for regular PC/Server traffic. See the notes section for info on this.

hostname Your-Switch-Stack-Name
no iscsi enable
interface range gigabitethernet 1/0/1-24
no flow control
interface range gigabitethernet 2/0/1-24
no flow control
interface range tengigabitethernet 1/0/1-2
no flow control
interface range tengigabitethernet 2/0/1-2
no flow control

Part 2 – Remove VOIP stuff

voice vlan oui-table remove 000181
voice vlan oui-table remove 0001e3
voice vlan oui-table remove 00036b
voice vlan oui-table remove 00096e
voice vlan oui-table remove 000fe2
voice vlan oui-table remove 001049
voice vlan oui-table remove 0060b9
voice vlan oui-table remove 00907a
voice vlan oui-table remove 00e0bb


Part 3 configure vlans

! replace X.X.X.X = IP address of switch vlan2

! replace Y.Y.Y.Y = IP address of switch vlan3

! check the range of ports you want to assign to each vlan

vlan database
vlan 2
vlan 3
exit
int vlan 2
ip address X.X.X.X 255.255.255.0
name iSCSI
exit
int vlan 3
name vMotion
ip address Y.Y.Y.Y 255.255.255.0
exit
interface range gigabitethernet 1/0/1-11
switchport access vlan 2
interface range gigabitethernet 2/0/1-11
switchport access vlan 2
exit
interface range gigabitethernet 1/0/12-14
switchport access vlan 3
interface range gigabitethernet 2/0/12-14
switchport access vlan 3
exit

Part 4 – Setup Passwords

This section sets up the passwords for telnet, ssh and enables http and https access to the switch.

! Replace ZZZZ = enable password (must be 8 chars!)

! WWWW = telnet and SSH password

! UUUU = hostname

! V.V.V.V = default gateway

username admin password ZZZZ priv 15
ip default-gateway V.V.V.V
enable password YYYY
aaa authentication login default line
aaa authentication enable default line
crypto certificate 1 generate key-generate
ip https secure-server
ip http authentication aaa login-authentication local
line ssh
login authentication default
enable authentication default
password WWWW
line telnet
login authentication default
enable authentication default
password WWWW
crypto key generate rsa
ip ssh server
exit
exit

Part 5 – Permanently save configuration

copy running-config startup-config

Notes

Use the below commands to individual configure the ports (e.g. if you have not/do not want to switch on iscsi mode in part 1)

port jumbo frame
interface range gigabitethernet 1/0/12-24
speed 1000
duplex full
no flowcontrol
spanning-tree portfast

Comments 7

Leave a Reply

Your email address will not be published. Required fields are marked *