Setup Script for Dell Powerconnect 6224 in iSCSI environment

The script below is designed to be used to setup a Dell Powerconnect 6224 to work with ESXi hosts and an iSCSI SAN. It assumes that the Dell switches are in a factory default state. This script creates 2 vlans with ports 2-16 used for iSCSI traffic and pots 17-19 used for vmotion.  Port 1 is left in the default vlan 1 and is used to administer the switch. There is also a 4 port aggregate uplink for switch-switch traffic although a better solution would be to use a stacking cable.

This is the setup I was using when I configured the scripts.

 

I have split the script into 6 parts for a better understanding of what each part does. Please connect your PC to the serial port on the back of the switches and use a terminal emulation program such as putty to paste in the below commands. You will need to enter “enable” and “configure” modes.

 

Part1 – Set Hostname and Enable Flow Control

 

! Replace UUUU with your desired hostname

hostname UUUU

flowcontrol

 

Part 2 – Disable spanning tree, set jumbo frames and switch off storm control

 

! NB – only disable spanning tree if there are only 1 or 2 switches.

interface range ethernet all

spanning-tree disable

mtu 9216

no storm-control unicast

exit

 

Part 3 – Configure ports 21-24 as switch-switch LAG

If you are stacking the switches you do not need to do this section.

lacp system-priority 120

interface range ethernet 1/g21-1/g24

lacp port-priority 247

lacp timeout long

exit

interface range ethernet 1/g21-1/g24

channel-group 1 mode on

exit

 

 

Part 4 configure vlans

 

! replace X.X.X.X = IP address of switch vlan2

! replace Y.Y.Y.Y = IP address of switch vlan3

 

vlan database

vlan 2

vlan 3

exit

int vlan 2

ip address X.X.X.X 255.255.255.0

name iSCSI

no routing

exit

int vlan 3

name vMotion

ip address Y.Y.Y.Y 255.255.255.0

no routing

exit

interface range ethernet 1/g1-1/g16

switchport access vlan 2

interface range ethernet 2/g1-2/g16

switchport access vlan 2

exit

interface range ethernet 1/g17-1/g19

switchport access vlan 3

interface range ethernet 2/g17-2/g19

switchport access vlan 3

exit

! The below is not needed if you are stacking the switches

interface port-channel 1

switchport mode trunk

switchport trunk allowed vlan add 2

switchport trunk allowed vlan add 3

mtu 9216

exit

 

Part 5 – Setup Passwords

 

! Replace ZZZZ = enable password (must be 8 chars!)

! WWWW = telnet password

! UUUU = hostname

! V.V.V.V = default gateway

 

username admin password ZZZZ level 15

ip default-gateway V.V.V.V

enable password YYYY

line telnet

password ZZZZ

exit

exit

 

Part 6 – Setup Management IP

! replace Q.Q.Q.Q with the desired management IP

! replace R.R.R.R with the desired default gateway

ip address Q.Q.Q.Q

ip default gateway R.R.R.R

 

Part 7 – Permanently save configuration

 

copy running-config startup-config

 

Other Notes

Please test the LAG to make sure it is passing vlan traffic. I have had problems setting this up the past. You may need to log onto the web interface and tag the port (i.e. mark the port with a “T”)

Comments 5

  • Thanks!

    I was wondering if you could go over some of your choices, like turning off spanning tree instead of using portfast, changing the lacp settings and the no storm-control unicast?

    Also its a good idea to turn off the unused ports to keep people from randomly plugging things into them and taking everything down, especially if spanning tree is off.

  • Thank you very much for this write up. It was exactly what I was looking for and worked out great.

    Nicely done and thanks again!!

  • nicely done, i’m strugling with the webinterface now to check the settings.

    But 6224 model is advised to use an stacking cable, if you don’t want to use such don’t buy this model. Just buy an higher model. It’s in the Dell’s white papers.

  • Couple of pointers to help those that find this due to having VLAN linking problems between the two switches.
    Disabling Spanning Tree is only necessary on the LAG (or single port!) that is interconnecting the two switches.

    You _should_ put any port or LAG that connects the two switches into Trunk mode (this will ensure that traffic stays on the right VLAN).

    You _should_ remove the default VLAN from the trunk which is used for iSCSI and vMotion.

    and finally – there are good reasons NOT to use stacking modules (even though this is against Dell best practice!). Stacking the switches effectively make this one switch; yes this will give you much simpler config (especially for VLANS, management, Spanning Tree setup etc.) but at the expense of some loss of redundancy. The redundancy you lose is this. Any firmware update will require you to take down the (now single) switch. Picture this scenario: switches configured in stack running well for a year or so. Suddenly one of them fails – no loss of connectivity for iSCSI so all is OK. BUT when you want to replace the failed switch it will have to be exactly the same firmware version as the one you have running. This might not be the case if it is a new / replacement switch. Also what happens if you want to update to newer firmware because of a bugfix or other issue? You will have to take down the entire stack during the update process.
    This may be possible, but it’s almost certainly some extra work. In lots of environments this won’t even be possible; if you need 24×7 availability of your iSCSI SAN even allowing for maintenance then you SHOULD NOT stack the switches.

  • Nice script. Simple and very fucntional thanks.

    It’s also important to note that you should disable STP on ports where you’re going to connect endpoints avoiding any “accidental” STP topology convergence impact.

    About stacking it’s a great note to take into account, thanks Bruce.

Leave a Reply

Your email address will not be published. Required fields are marked *