Sample iSCSI config for Dell Powerconnect 5424

Below is a sample config for use with ESX/ESXi
!

! *** NEED TO CHECK telnet/http ACCESS RIGHTS ON THIS ***

!

! Script to configure Dell Powerconnect 5424 for ESX/iSCSI – AE Jan 2010

! Ports 1-16 = vlan 100 = iSCSI network

! Ports 17-19 = vlan 101 = vMotion

! Ports 20-24 = Aggregated Uplink

!

! Replace….

! X.X.X.X = IP address of switch vlan100

! Y.Y.Y.Y = IP address of switch vlan101

! ZZZZ = enable password (must be 8 chars!)

! WWWW = telnet password

! UUUU = hostname

! V.V.V.V = default gateway

!————————————————————-

hostname UUUU

port jumbo-frame
spanning-tree mode rstp

interface range ethernet all

No port storm-control broadcast enable

flowcontrol on

spanning-tree portfast

exit

vlan database

vlan 100-101

exit

int vlan 100

ip address X.X.X.X 255.255.255.0

name iSCSI

exit

int vlan 101

name vMotion

ip address Y.Y.Y.Y 255.255.255.0

exit

interface range ethernet g(1-16)

switchport access vlan 100

exit

interface range ethernet g(17-19)

switchport access vlan 101

exit

interface port-channel 1

switchport mode trunk

switchport trunk allowed vlan add 100

switchport trunk allowed vlan add 101

exit

interface range ethernet g(21-24)

channel-group 1 mode on

exit

username admin password ZZZZ level 15

ip default-gateway V.V.V.V

enable password level 15 YYYY

line telnet

password ZZZZ

exit

voice vlan oui-table remove 00036b

voice vlan oui-table remove 00096e

voice vlan oui-table remove 0001e3

voice vlan oui-table remove 000fe2

voice vlan oui-table remove 0060b9

voice vlan oui-table remove 00d01e

voice vlan oui-table remove 00e075

voice vlan oui-table remove 00e0bb

no iscsi enable

no iscsi target port 860

no iscsi target port 3260

exit

copy running-config startup-config

Leave a Reply

Your email address will not be published. Required fields are marked *