Setup HP 4210G for iSCSI use

The below configuration example is for a HP (or 3Com) 4210G to be used in a iSCSI storage network.

  • There are 3 vlans configured with
  • Ports 21,22,23,24 configured as an uplink for all vlans.
  • Flow control and jumbo frames are also enabled.

Example config

 

<4210G>display saved-configuration

#

version 5.20 Release 2202P18, Release 2202P18

#

sysname 4210G

#

irf mac-address persistent timer

irf auto-update enable

undo irf link-delay

#

domain default enable system

#

telnet server enable

#

undo cluster enable

#

igmp-snooping

#

vlan 1

igmp-snooping enable

#

vlan 2

description iSCSI

#

vlan 3

description Heartbeat

#

radius scheme system

server-type extended

primary authentication 127.0.0.1 1645

primary accounting 127.0.0.1 1646

user-name-format without-domain

#

domain system

access-limit disable

state active

idle-cut disable

self-service-url disable

#

user-group system

#

local-user admin

authorization-attribute level 3

service-type telnet terminal

local-user manager

password simple manager

authorization-attribute level 2

service-type telnet terminal

local-user monitor

password simple monitor

authorization-attribute level 1

service-type telnet terminal

#

interface NULL0

#

interface Vlan-interface1

ip address 192.168.99.1 255.255.255.0

#

interface Vlan-interface2

ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/2

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/3

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/4

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/5

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/6

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/7

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/8

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/9

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/10

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/11

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/12

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/13

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/14

port access vlan 2

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/15

port access vlan 3

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/16

port access vlan 3

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/17

port access vlan 3

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/18

port access vlan 3

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/19

port access vlan 3

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/20

port access vlan 3

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/21

port link-type trunk

port trunk permit vlan all

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/22

port link-type trunk

port trunk permit vlan all

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/23

port link-type trunk

port trunk permit vlan all

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/24

port link-type trunk

port trunk permit vlan all

speed 1000

duplex full

flow-control

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/25

port access vlan 2

speed 1000

duplex full

flow-control

shutdown

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/26

port access vlan 2

speed 1000

duplex full

flow-control

shutdown

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/27

port access vlan 2

speed 1000

duplex full

flow-control

shutdown

broadcast-suppression pps 3000

stp edged-port enable

#

interface GigabitEthernet1/0/28

port access vlan 2

speed 1000

duplex full

flow-control

shutdown

broadcast-suppression pps 3000

stp edged-port enable

#

snmp-agent

snmp-agent local-engineid 80000XXXXXXA7B90D

snmp-agent community read public

snmp-agent community write private

snmp-agent sys-info version all

#

user-interface aux 0

authentication-mode scheme

user-interface aux 1 3

user-interface vty 0 4

authentication-mode scheme

#

return

<4210G>

Leave a Reply

Your email address will not be published. Required fields are marked *