Setup Powerconnect 5524 5548 for network Use

In this example I am setting up 1x 5524P as the core with 2x 5548P switches used for distribution. These switches are to be used for networking only (no iSCSI).

They are being setup with a vlan for data (vlan1), a voice vlan (100) and wireless vlan (50). Initially only vlan1 will be used.

 

Stacking The Switches

  • In this example I have stacked the 3 switches with the top switch (number 1) connecting to HDMI port 2 on switches 2 and 3. There is also a cable between HDMI ports 1 on switches 2 and 3.
  • Power on the switches from top to bottom letting each switch power on fully before the next. You should then get the displays showing 1-2-3 as below.

This can be confirmed by running the show switch command. Notice the topology is listed as “Ring”.

 

Initial Configuration

The below commands will specific a hostname, setup SSL, enable IP routing and specify the default gateway.

hostname XXXXXX

crypto key generate rsa

ip ssh server

ip routing

ip route 0.0.0.0 0.0.0.0 192.168.26.2

 

Disable iSCSI Optimisations, Jumbo Frames and Flow Control

Assuming the switches are not being used for iSCSI, and you do not have flow control and jumbo frames in use. Log onto the switch via the console cable and enter configuration mode. Enter the below commands:-

no iscsi enable

no port jumbo-frames

no iscsi target port 860 address 0.0.0.0

no iscsi target port 3260 address 0.0.0.0

no iscsi target port 9876 address 0.0.0.0

no iscsi target port 20002 address 0.0.0.0

no iscsi target port 20003 address 0.0.0.0

no iscsi target port 25555 address 0.0.0.0

To disable flow control for each interface. As we have 3 switches

int range gi1/0/1-24

no flowcontrol

int range te1/0/1-2

no flowcontrol

int range gi2/0/1-48

no flowcontrol

int range te2/0/1-2

no flowcontrol

int range gi3/0/1-48

no flowcontrol

int range te3/0/1-2

no flowcontrol

 

Configure Vlans

int vlan 50

name wireless

ip address 192.168.50.2 255.255.255.0

int vlan 100

ip address 192.168.100.2 255.255.255.0

 

The setup the ports for vlans

int range gi1/0/1-24

desc “Voice \ Data port”

spanning-tree portfast

switchport mode trunk

switchport trunk native vlan 1

switchport trunk allowed vlan add 1,50,100

 

int range gi2/0/1-48

desc “Voice \ Data port”

spanning-tree portfast

switchport mode trunk

switchport trunk native vlan 1

switchport trunk allowed vlan add 1,50,100

 

int range gi3/0/1-48

desc “Voice \ Data port”

spanning-tree portfast

switchport mode trunk

switchport trunk native vlan 1

switchport trunk allowed vlan add 1,50,100

Note that you do not have to enter the command “switchport trunk native vlan 1” as this is the default anyway. I have included it in case you want to change to another vlan.

 

Setup Usernames and Passwords

This section sets up the passwords for telnet, ssh and enables http and https access to the switch.

! Replace ZZZZ with admin password (must be 8 chars!)

! WWWW = telnet and SSH password

! YYYYY = enable password

! VVVVV = console password

username admin password ZZZZ priv 15

enable password YYYY

aaa authentication login default line

aaa authentication enable default line

crypto certificate 1 generate key-generate

ip https secure-server

ip http authentication aaa login-authentication local

line ssh

login authentication default

enable authentication default

password WWWW

line telnet

login authentication default

enable authentication default

password WWWW

line console

password VVVV

 

Save Config

Most importantly don’t forget to save your changes.

Copy run start

You can backup the config to a USB key fob (inserted into switch 1) with the command

    Copy run usb://filename

(Change filename to whatever you want to call the backup file)

 

END

Leave a Reply

Your email address will not be published. Required fields are marked *